Limited-Time Donation Special!
Upgrade to Snow for $20 USD and receive a free copy of Oblivion Light ($5 discount).
Upgrade to +Blizzard for $35 USD and receive a free copy of Oblivion Light ($15 discount).

Please visit the thread below for more details.
CLICK HERE

Contact @Davlin with questions or comments.

Jump to content
  • 0
Denetor

Dangerous PHP Functions Enabled

Question

Posted (edited)

Dangerous PHP Functions Enabled

We recommend disabling the following functions on your server, or at least in the directory that your community is installed in. If you do not manage your server yourself, your hosting provider will be able to assist with this.
exec, system, popen, proc_open, shell_exec

 

 

 

Hi all, just wondering how does these issues can be fixed?, i contacted to the host tech support but that warning is still there in the dashboard.

Edited by Denetor

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 1

You would need to modify your php.ini file and add this line.

disable_functions = "exec, system, popen, proc_open, shell_exec"

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, antarsis said:

You would need to modify your php.ini file and add this line.

disable_functions = "exec, system, popen, proc_open, shell_exec"

 

Thanks for your response :)

already did it but it doesn't seems to work 😵 the file is in the directory where the community is installed in.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Denetor said:

 

Thanks for your response :)

already did it but it doesn't seems to work 😵 the file is in the directory where the community is installed in.

It should be in the directory /etc/php/php(version)/

You need a root ssh access but...

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I am also seeing this warning after upgrading to 4.3 (from 4.2) - but have checked (own managed server with root access) and those php functions are actually NOT enabled (nor are "display_errors").

:(

1100549807_ScreenShot2018-08-03at5_42_41PM.thumb.jpg.48c7d2df8cf96d5cb0d5bdaf9dec0367.jpg

Wondering if it could be false-positive caused by non-standard location of php.ini files? (ie. using ServerPilot)

Share this post


Link to post
Share on other sites
  • 0
23 minutes ago, Caseir said:

I am also seeing this warning after upgrading to 4.3 (from 4.2) - but have checked (own managed server with root access) and those php functions are actually NOT enabled (nor are "display_errors").

:(

1100549807_ScreenShot2018-08-03at5_42_41PM.thumb.jpg.48c7d2df8cf96d5cb0d5bdaf9dec0367.jpg

Wondering if it could be false-positive caused by non-standard location of php.ini files? (ie. using ServerPilot)

Did you check the global php.ini for the server or possible your site specific php.ini ;) 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

those functions are not available on shared hosting or on some  shared cloud system, the only way to not have that kind of alert its having in most case  a private server or something where you can manage yourself your phph functions, and shared hosting will not change this functions for you 

Edited by killshandra
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
On 01/08/2018 at 12:34, Denetor said:

Funções Perigosas do PHP Habilitadas

Recomendamos desabilitar as seguintes funções em seu servidor ou, pelo menos, no diretório em que sua comunidade está instalada. Se você não gerencia seu servidor sozinho, seu provedor de hospedagem poderá ajudá-lo.
exec, system, popen, proc_open, shell_exec

 

 

 

Oi tudo, só querendo saber como esses problemas podem ser corrigidos ?, eu entrei em contato com o suporte técnico do host, mas esse aviso ainda está lá no painel.

 

Friend this is happening in the general forum in my and my clients'

Share this post


Link to post
Share on other sites
  • 0

ok, i tried everything that was suggested here (thanks alot) but i can not get rid of this warning, my hosting is not a shared service (from what i know) so i don't know what else i can do 😔.

Share this post


Link to post
Share on other sites
  • 0

ok, after making a revision i finally got rid of this warning message by adding the said command line into the cp console in the php settings and fixing the line adding athe [ ] signs.

 

Thanks alot to everyone for your assistance :D

Share this post


Link to post
Share on other sites
  • 0
The question(s) in this support topic have been answered and the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

Share this post


Link to post
Share on other sites
What do you think? Remember the human.
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×