Jump to content
We're hiring! We are accepting applications for Junior Moderator, Uploader, and Support Team. Read more... ×
If you use a disposable / throwaway email, you need to change it. Read more... ×

0x00000F

Frost
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

1 Neutral

1 Follower

About 0x00000F

  • Rank
    ez clap

Profile Information

  • Software
    IPS4
  • Version
    4.2

Contact Methods

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. yo, I'm searching for around 2 USD in bitcoin for like an hour or so. I'd like to exchange with PayPal. if anyone of you has such amount left, lemme know here or in discord, that'd help me a lot. thanks.
  2. Yo, I have around 20 users on my site and most of them are customers. I take privacy very serious and I am trying to disable the customer billing address information in the ACP. As soon as a customer pays with his paypal for a subscription, IPB sets their real name, country, city, street and even their phone number in the customer's profile. Is there any way to disable this? I do not wish to have their info anywhere on my server/site stored. Thank you!
  3. Fixed! How I found it: I downloaded the newest IPB version, started Sublime Text 3 and searched for 3S290/3, found one file which was located in "root/system/Dispatcher/Api.php". On line 187 you see it shifts the array of URL-bits, then it checks for a regex and throws the error. I commented the exception throw and used print_r/var_dump to check what the variable $app contains. Surprisingly the array was empty. I then checked what $pathBits does and it seemed as expected, that it doesn't apply any of the URL-bits to the variable. (reason for that remains unknown to me, I'm not a IPB dev nor a plugin-freak. So I just did a workaround to fix my issue.) Solution: A small workaround on line 84 fixed that issue. /* Get the requested URI */ $requestURI = $_SERVER['REQUEST_URI']; /* Remove /api/ from the bits */ $requestURI = str_replace("/api/", "", $requestURI); /* Finally apply the new URL-bits to $pathBits */ $pathBits = array_filter( explode( '/', $requestURI ) );
  4. still "INVALID_APP". Do you mind telling me what files/directories does contain your root/api folder? I remember I had my own api (standalone) running on my site, when I installed IPB, I noticed IPB uses the same name for their API as I do with mine. So I had to remove the index.php (in API folder) when I was installing because I was scared it would override my own API. #edit: I found something interesting .. apparently I have a .htaccess file in the API folder. If I remove it, IPB gives me "page not found". If I add .htaccess back, it says "INVALID_APP". It seems like something is wrong in the .htaccess file. I think it reads "/api/" as the first level and uses that as APP and then it goes like second level which is "core", meaning it will throw an error because "/api/core/" isn't but "/core/hello" is a valid app on the forums.
  5. It's literally the same code as on the official IP site. @https://invisioncommunity.com/developers/rest-api <?php $communityUrl = 'http://localhost:8888/ips4/'; // my forum url $apiKey = 'c7a349a1629f02cd2855a58d77646f6d'; // my test key $curl = curl_init( $communityUrl . 'api/core/hello' ); // doesn't matter what call I do, I get the same error code. ~ And yes, I do have set the permissions for all calls available for my test key. curl_setopt_array( $curl, array( CURLOPT_RETURNTRANSFER => TRUE, CURLOPT_HTTPAUTH => CURLAUTH_BASIC, CURLOPT_USERPWD => "{$apiKey}:" ) ); $response = curl_exec( $curl ); echo $response;
  6. Yo, tldr; I'm trying to make a simple request (core/hello). Auth seems ok but it looks like that there is something wrong with the call or "special characters" as the error code says on IP's "understanding errors". ~ sounds weird but I never had this issue with any other board I had back in days. I am actually lost. I was trying hard to fix this by checking my database, permissions set to directories and all that .. Any help is appreciated!
    Theme looks great but whenever I try to install it, it gives me SERVER_ERROR 500. :/ Using IPB 4.1.15
  7. The point is, that every big antivirus company use the same technology (or at least the engine) to catch viruses. This is called the AV Engine. It's almost the same as you would buy a graphiccard from ZOTAC, Gainward etc. They are all based on NVIDIA's GPU and Gainward upgrades it with 2 or 3 fans, better looking case and stuff.
  8. Yo guys, As the title says, I'm actually searching for a good and nice looking donation addon for my friend's forum. Thanks!
  9. enjoy my $10! :) I'm sure I will donate more over time. So, be prepared! :D
×