Jump to content

[WF NULL] IPS Community Suite 4.3.6

   (45 reviews)
Sign in to follow this  

1 Screenshot

About This File

IPS Community Suite 4.3.6

Released 9/20/2018


WebFlake Note: Please create a support topic if you need assistance.

As always, we recommend that you backup your current installation (database included) before upgrading.


What's New in Version 4.3.6   See changelog

Released

Key Changes

This is a maintenance release to fix reported issues.

Additional Information

Core - Members & Accounts

  • Added ability to use bulk mail subscription status as a filter for group promotions.
  • Fixed profanity filters applying to account usernames during registration.
  • Fixed following a member not updating the follow button correctly.
  • Fixed filters when creating a bulk mail or downloading a member list not working in certain combinations.
  • Fixed inability to manually set a member's reputation count less than 0.

Core - Search & Activity Streams:

  • Improved performance of indexing content when using Elasticsearch.
  • Improved the phrasing of the description on search results page when a custom date range has been chosen to sound more natural.
  • Fixed some Elasticsearch queries not working on very high traffic sites.
  • Fixed an issue where content that had been restored after being deleted would not be reindexed correctly.
  • Fixed an issue with Elasticsearch where content that had been hidden or moved would not be reindexed correctly.
  • Fixed filtering by specific members when using Elasticsearch.
  • Fixed various issues with activity streams not behaving correctly.

Core - Posting & Post Content:

  • Improved message when embedded content is not available to indicate if the content has been deleted or the user doesn't have permission to see it.
  • Fixed some Emojis rendering incorrectly.
  • Fixed broken TED Talks embeds.

Core - Clubs:

  • Fixed pagination of the list of members in a club not working.
  • Fixed some moderator permissions not applying correctly within clubs.
  • Fixed paid clubs being able to be created with $0 fee.
  • Fixed granting permission to create specific types of clubs via secondary groups not working properly.
  • Fixed content rebuild task not running on custom fields for clubs.

Core - Sitemap

  • Fixed some items not included in the sitemap.
  • Fixed error generating the sitemap when entering zero for the number of items to include.
  • Fixed sitemap not generating on some PHP versions.

Core - Redis:

  • Added ability to use Redis as a data storage method if is also being used as the caching method.
  • Fixed online users older than 30 minutes showing when using Redis.
  • Fixed uncaught exception that may occur when using Redis and clearing caches.

Core - Misc

  • Added a warning to the AdminCP dashboard, and when editing the login handler, if Facebook login is enabled but site is not using https. Also changed the Facebook login setup process to not allow new setups if site is not using https.
  • Added an option to use a different Facebook application for social promotion (opposed to the Facebook application used for login) so that Facebook login is not affected while your Facebook app is under review.
  • Added logging any time the support tool has been run.
  • Improved session handling performance.
  • Improved performance of viewupdates task.
  • Improved performance of queue task.
  • Fixed announcements being shown before the start date.
  • Fixed error when deleting the node being viewed in AdminCP node trees.
  • Fixed copying some node settings in the AdminCP not working.
  • Fixed replacement tags not working in bulk mails within URLs.
  • Fixed lost image style attributes in bulk emails.
  • Fixed Acronym Expansion page in AdminCP not line breaking correctly for very long values, breaking the page layout.
  • Fixed profile field management checking wrong AdminCP restriction.
  • Fixed CSS and JavaScript files not being deleted when recompiled on upgrade or when running the support tool.
  • Fixed false warnings from the database checker when using MySQL 8 and in certain other edge cases.
  • Fixed error after changing cache or datastore settings in certain PHP configurations.
  • Fixed link to the setting for allowed characters in usernames (which shows when setting up certain login handlers) not highlighting the setting.
  • Fixed possible error when creating the default English language when running the support tool.
  • Fixed AdminCP dashboard warning about failed tasks showing for disabled tasks.
  • Fixed browsers potentially keeping a cache of outdated JavaScript files.
  • Fixed JSON-LD data for ratings in several apps.
  • Fixed some widgets not limiting results correctly which could cause performance issues.
  • Fixed a possible technical error message (rather than a graceful error screen) showing if a very low-level error (such as database server offline) occurs in certain circumstances.
  • Fixed a missing warning when the hooks.php file was not writable before application and plugin installations and upgrades.
  • Fixed an issue when using profile complete and forum specific themes.
  • Fixed uncaught exception if manually going to a specific URL to try to promote something which cannot be promoted.
  • Fixed an unnecessary redirect in the applications upgrade process.
  • Fixed some minor language string inconsistencies.
  • Removed logging of notices that a template was requested to be rebuilt while already rebuilding.
  • Check to ensure that https is used before allowing Facebook to be used as a log in handler.
  • Fixes a read/write separation issue with unhiding

Forums

  • Fixed moderator permissions for posts.
  • Fixed an issue where moving archived topics from one forum to another did not update the forum counters.
  • Fixed an issue where posting a hidden post causes the forum to indicate a post pending approval is present.

Commerce

  • Added an option when refunding a transaction which was paid by a PayPal Billing Agreement to also cancel the Billing Agreement.
  • Added support for AUD, CZK, DKK, HKD, ILS, MXN, NZD, NOK, PHP, PLN, RUB, SGD, SEK, SEK, CHF, and THB for PayPal card payments.
  • Fixed automatic recurring payments for subscriptions not re-subscribing members correctly.
  • Fixed subscription upgrades/downgrades not being available at all to plans which are set to only be payable by particular gateways, or whose base price is modified by the chosen renewal term.
  • Fixed missing language strings in member history when upgrading subscriptions.
  • Fixed missing tax on purchase reactivation.
  • Fixed not being able to remove product discounts.
  • Fixed incoming emails being saved as blank replies.
  • Fixed incoming emails from certain email address formats, including emails using new domain extensions.
  • Fixed the link to print an invoice that gets sent in the email not working for guests.
  • Fixed missing language strings in the email advising a user their support request will automatically be marked resolved.
  • Fixed invalid referral banner image URL shown to users.
  • Fixed broken referrer tab in AdminCP customer profile.
  • Fixed broken images when viewing a purchase of an advertisement in the AdminCP.
  • Fixed advertisement purchases created by generating an invoice in the AdminCP.
  • Fixed possible text overflow when viewing shipping order in AdminCP.
  • Fixed support requests not showing assigned staff member in preview.

Pages

  • Fixed the page BBCode and editor button which allows content to be split over multiple pages.
  • Fixed incorrect sorting of number database fields.
  • Fixed search permissions when changing the "User can see records posted by other users" setting for a database.
  • Fixed an error occurring when editing a comment that is synced with a topic that has been hidden.
  • Fixed numeric database fields which use more than 2 decimal places in the value.
  • Fixed an issue where using a custom field validator with a unique field would mean the unique check is skipped.

Gallery

  • Fixed broken redirect after deleting an album and moving images in it to a category.
  • Fixed broken promote form for images within an album.
  • Fixed missing watermark when a file was inserted via the "Insert other media" feature.

Downloads

  • Fixed screenshots that have been imported from a URL missing from embeds.

Blog

  • Fixed blog cover photo being used when sharing entries on social media even when the entry has its own feature photo.
  • Fixed broken Blog Embeds.
  • Fixed link to the last Blog Entry inside the Blog Embed.

Calendar

  • Fixed cover photo offset not copying correctly when copying events.
  • Fixed venue not saving from ical upload.

REST & OAuth

  • Fixed OAuth setups refreshing refresh tokens more often than they should.
  • Fixed OAuth setups not properly supporting implicit grants.

Converters

  • Added support for redirecting direct post links for Vanilla.
  • Improved performance of conversions.
  • Improved description of minimum version for vBulletin 3 conversions.
  • Fixed error with login after conversion.
  • Fixed extraneous breaks in content converted from vBulletin.
  • Fixed personal conversations from Vanilla.
  • Fixed Gallery albums being converted with no default sort option.
  • Fixed issue with converting Calendar Event attachments.
  • Fixed issue where some code box content may be broken after conversion from phpBB.
  • Fixed vBulletin 3 redirects no longer working if you converted prior to upgrading to 4.x.

Upgrader

  • Added UConverter support to the UTF-8 Converter for sites with mixed character sets.
  • Fixed an issue where announcement widgets may not get removed when upgrading to 4.3.
  • Fixed possible SQL error when upgrading Calendar from 3.x.
  • Fixed how sharedmedia BBCode gets converted to embeds for Gallery albums when upgrading from 3.x.
  • Fixed an issue where converting to UTF-8 prior to upgrade can throw an error in some situations.
  • Fixed Gallery sitemap showing incorrect date for images upgraded from 3.x.

Third-Party / Developer / Designer Mode

  • Fixed album embeds when in developer mode.
  • Fixed errors adjusting sitemap configuration preferences when using developer mode
  • Like 134
  • Thanks 75
  • Haha 2
  • Confused 2
  • Upvote 40
  • Downvote 2




User Feedback

You may only provide a review once you have downloaded the file.


Wyattlgpie

   5 of 5 members found this review helpful 5 / 5 members

Worked great for my website! Keep up all the fantastic work!!!

Share this review


Link to review
GuguGRP

   3 of 3 members found this review helpful 3 / 3 members

Very Thanks! My last version is old.

Share this review


Link to review
yuniel_leal

   3 of 3 members found this review helpful 3 / 3 members

The best Forum app site ever. Thank's a lot for sharing to us...

Share this review


Link to review
tkclients

   3 of 3 members found this review helpful 3 / 3 members

Thanks Davlin, I'm testing it!

Share this review


Link to review
pioj

· Edited by pioj

   2 of 2 members found this review helpful 2 / 2 members

Upgraded with some issues...(please check my thread about upgrading)

I can't currently install anything (plugins, apps, templates, none). Everytime I submit the file, this appears:

cFn6Lgt.png

The rewrite module is already loaded, and I set correctly the UPLOAD_TMP_DIR and OPEN_BASEDIR in the php.ini configuration. I also ensured there is a AllowOverride All in my site config and the apache common config. No system logs or error logs show anything related. The whole site root folder has chmod 777, btw...

 

I'm out of ideas, so please, help.

Share this review


Link to review
SanderAli

   2 of 2 members found this review helpful 2 / 2 members

Very thanks Davlin

Share this review


Link to review
demon1234

   2 of 2 members found this review helpful 2 / 2 members

Just something is wrong with mail. users are not receiving verification mail.

Response from the author:

This is not an issue with the release but rather an issue with your configuration and/or host.

Share this review


Link to review
asandru

· Edited by asandru

   1 of 1 member found this review helpful 1 / 1 member

Hi, how safe is to use this version for example for a non comercial community?

Share this review


Link to review
Hizom

   1 of 1 member found this review helpful 1 / 1 member

it's working fine on my side. nice share. thx.

Share this review


Link to review
Ednargocat

   1 of 1 member found this review helpful 1 / 1 member

Thanks for this.  Upgrading my site now.

Share this review


Link to review
the_bluenose

   1 of 1 member found this review helpful 1 / 1 member

Thanks Davlin! You my friend are a god!

Kudos.

Share this review


Link to review
shinnjihideaki

   1 of 1 member found this review helpful 1 / 1 member

There is something wrong with the 4.3.0 nulled version. Each time I install or upgrade to it, it shows error in the suite cp. It doesn't load and shows that there is a problem. When viewing the error logs on cpanel, shows there is something wrong with theme.php line 1695 but doesn't find the  wrong and don't know how to fix it. The admin panel is fine though except the main page. Please respond ASAP to know how to fix as I have deleted everything in my forum trying to fix but nothing works.

Share this review


Link to review
paulo_crash

   1 of 1 member found this review helpful 1 / 1 member

Doubt, this version has Clubs, understood but I can not activate, if I have as active?

Share this review


Link to review
Hey Lindy, I'm PsYcHo_RaGE

   1 of 1 member found this review helpful 1 / 1 member

Thank you very much for this buddy

i really appreciate your work here, Thanks :) 

  • Like 1

Share this review


Link to review
bendeguzbagi

· Edited by bendeguzbagi

   1 of 1 member found this review helpful 1 / 1 member

A.W.E.S.O.M.E!!!!!!!! But.... I installed to my google cloud vm and the calendar not working very well.....

EDIT: I figured it out :) Everything working fine! Thanks again!!!

  • Like 2

Share this review


Link to review
gooboy

   1 of 1 member found this review helpful 1 / 1 member

Thanks a heap mate!

  • Like 2

Share this review


Link to review
Ieva

· Edited by Ieva

   1 of 1 member found this review helpful 1 / 1 member

Works very well  :) 

  • Like 1

Share this review


Link to review
fielderJ

   17 of 18 members found this review helpful 17 / 18 members

successfully upgraded.

NOTE: If you have changed your admin directory, upload the files and folders inside the admin installation folder to your renamed folder. If not you will get a session error.

I am still trying to enable open_basedir. 

upgrade_successful.thumb.png.13f0f2cd31686a70114232e6282b40ec.png

  • Like 5

Share this review


Link to review
shihuang214

   6 of 7 members found this review helpful 6 / 7 members

Thanks Davlin!

Share this review


Link to review
mr-pimpen

   6 of 7 members found this review helpful 6 / 7 members

this worked perfect i add to the upgrade fix every thing from my last download

  • Like 1

Share this review


Link to review
PlanetMaster

   4 of 5 members found this review helpful 4 / 5 members

Thanks as always for the shares, came here for 4.3.6 but not up yet will check back in 24.

Share this review


Link to review
kevinexit

· Edited by kevinexit

   4 of 5 members found this review helpful 4 / 5 members

upgraded successfully... no problem found 

Promote Function doesn't seem to be working in this version (4.3.***)

Thanks Again Davlin... please review my profile!:sob:

  • Confused 1

Share this review


Link to review
jackb8

   4 of 5 members found this review helpful 4 / 5 members

search member on admincp dont work

Response from the author:

This was a known issue with 4.3.3 and IPS has resolved it with the latest release.

Share this review


Link to review
Mantinho7

   3 of 4 members found this review helpful 3 / 4 members

I install it on FileZilla public.html , but nothing happens, when I open my domain in browser it still writes "upload ur website into public.html directory". If I try to write like my domain/admin it writes : Parse error: syntax error, unexpected '[' in /home/pradedanty/domains/pradedantysis.us.lt/public_html/system/Dispatcher/Admin.php on line 363

Mb someone knows why I cant install it? 🙄

Response from the author:

Please use our support forums.

Share this review


Link to review
Paul A

   2 of 3 members found this review helpful 2 / 3 members

Thank you!

Share this review


Link to review
×
×
  • Create New...

Important Information

WebFlake uses cookies to ensure that you get the best experience possible within our community. More Info